Debian 10/11 升级内核Linux Kernel

大家在抢到各种小鸡开机选择Debian系统的时候,一般会选择一键DD成纯净的Debian系统,DD之后Debian10的内核是4.19

Debian11的是5.10,当需要新版内核支持,比如wireguard默认加载在5.0以上内核,一键开启bbr的时候。

需要更新内核,本方式适合大多数版本的Debian,目前尝试过Jessie、buster、bullseye。

第一步,查询

查询当前Debian版本的backports支持。进入  Debian Backports  或者 Debian package list  网站查询

可以看到有 [  stretch-backports  ] [  stretch-backports-sloppy  ]  [  buster-backports  ]  [  bullseye-backports  ]等等

第二步,搜索内核

找到 【Kernel 】 分类,按“ CRTL + F ” 搜索关键词“linux-image”,可以看到当前最新的Linux kernel版本。

比如:linux-image-amd64 (5.10.103-1~bpo10+1)。

注意内核版本有amd64、arm64、rpi,还有个带cloud的内核,基本用于vps,比如

linux-image-cloud-amd64 (5.10.103-1~bpo10+1):Linux for x86-64 cloud (meta-package)

linux-image-cloud-arm64 (5.10.103-1~bpo10+1):Linux for arm64 cloud (meta-package)

linux-image-amd64 (5.10.103-1~bpo10+1):Linux for 64-bit PCs (meta-package)

linux-image-arm64 (5.10.103-1~bpo10+1):Linux for 64-bit ARMv8 machines (meta-package)

linux-image-rpi (5.10.103-1~bpo10+1):Linux for Raspberry Pi and Pi Zero (meta-package)

 

第三步:安装

下面一Debian bullseye为例,Debian buster把bullseye-backports更换成buster-backports

apt install vim -y #安装vim
vi /etc/apt/sources.list #修改源
#在最后添加一行
deb http://deb.debian.org/debian bullseye-backports main
#注意 根据你的版本号改一下【bullseye-backports】
apt update #更新一下软件列表
apt install -t bullseye-backports linux-image-cloud-amd64 linux-headers-cloud-amd64
注意:最后内核更新ARM机器直接换成linux-image-cloud-arm64、linux-headers-cloud-amd64

 第四步:重启

安装完成后,重启reboot一下,用 uname -a 命令看一下,就是最新内核了。

这时候apt update一下,可能会提示运行  apt autoremove -y 来删除旧的内核。

版权声明:
作者:Lewss
链接:https://www.amzcn.com/thread-03299-1.html
来源:AmzCN – 普通人的普通世界
文章版权归作者所有,未经允许请勿转载。

THE END
分享
二维码
< <上一篇
下一篇>>
文章目录
关闭
目 录